File prediction errors for instant learning models in US region
Incident Report for Nanonets
Postmortem

Incident Summary: Between 03:50 PM IST and 04:08 PM IST on January 21, 2025, users of app.nanonets.com experienced failures in processing requests related to Instant Learning Models. This issue was isolated to our secondary db, which encountered an operational issue, causing request failures. All other APIs and services remained unaffected.

Resolution: The above issue impacted reads for Instant Learning Models. Our engineering team promptly resolved the read replica issue, restoring full service functionality. The platform is now operating as expected. We sincerely apologize for the inconvenience caused and deeply regret the disruption to our users. Ensuring high availability and reliability of our services is our top priority.

Posted Jan 21, 2025 - 11:17 UTC

Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 10:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2025 - 10:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 21, 2025 - 10:37 UTC
Investigating
We are currently investigating this issue.
Posted Jan 21, 2025 - 10:32 UTC
This incident affected: API.