Delayed file processing for all models using async api

Incident Report for Nanonets

Postmortem

On April 11th, 2025, between 11:35 AM UTC and 12:45 PM UTC, users experienced delays in file processing across all models on the async prediction API of app.nanonets.com. There is no impact on EU and IN region. The issue was caused by an internal service dependency that became bottlenecked, leading to a backlog in the processing queue. The root cause was promptly identified, and a fix was deployed to restore normal processing. We sincerely apologize for the inconvenience caused and we are taking steps to prevent similar occurrences in the future.

Posted Apr 11, 2025 - 13:20 UTC

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 13:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 12:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 11, 2025 - 12:47 UTC

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 12:44 UTC
This incident affected: API.