Delay in file processing for Instant learning models in US region

Incident Report for Nanonets

Postmortem

One of our core processing services experienced an unexpected surge in load, which slowed down parts of our system and led to a backlog in processing. Our engineering team identified the underlying bottleneck and implemented fixes to stabilize performance. We are also rolling out improvements to make our platform more resilient to sudden spikes in usage.

We sincerely apologize for the inconvenience caused.

Posted Dec 12, 2025 - 07:46 UTC

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 09:52 UTC

Monitoring

Our sync API is now operating normally. For async uploads, most results are already available and any remaining pending results will be processed within the next few minutes as we clear the backlog.

Our team is addressing the issue on priority. We sincerely apologize for the inconvenience caused.
Posted Dec 11, 2025 - 09:30 UTC

Investigating

We are currently investigating this issue.
Posted Dec 11, 2025 - 07:56 UTC
This incident affected: API.