Service Degradation on app.nanonets.com
Incident Report for Nanonets
Postmortem

We sincerely apologize for the inconvenience caused by today's service disruption between 14:20 IST and 17:00 IST. A feature deployment caused unexpected pressure on our database, leading to request timeouts and elevated 5xx errors.

We have since rolled back the feature and restored normal operations. To prevent such issues in the future, we are strengthening our testing procedures and monitoring systems.

Thank you for your understanding and continued support. If you have any further questions or concerns, please contact our support team.

Posted Nov 24, 2024 - 11:47 UTC

Resolved
This incident has been resolved.
Posted Nov 24, 2024 - 11:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2024 - 10:21 UTC
Identified
We have identified the issue and working on a fix
Posted Nov 24, 2024 - 10:18 UTC
Investigating
We are currently investigating this issue.
Posted Nov 24, 2024 - 10:08 UTC
This incident affected: API and Web App.