Instant learning model prediction issues in EU and EU-Open Regions.
Incident Report for Nanonets
Postmortem

Incident Summary:

Instant learning models in EU and EU-Open regions experienced failures, resulting in request timeouts and service disruptions during the incident.

Root Cause:
A dependency conflict occurred when an external library update introduced incompatibility with a critical system component, leading to failure in processing requests.

Resolution:
The issue was addressed by pinning the affected library versions to known stable releases, ensuring compatibility across components. Moving forward, we have strengthened our dependency management processes to include proactive monitoring and testing of third-party updates to prevent similar issues

Posted Dec 03, 2024 - 04:31 UTC

Resolved
This incident has been resolved.
Posted Dec 02, 2024 - 10:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2024 - 09:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 02, 2024 - 08:59 UTC
Investigating
We are currently investigating this issue.
Posted Dec 02, 2024 - 08:45 UTC
This incident affected: API.