Delayed file processing for ILM models in app.nanonets.com

Incident Report for Nanonets

Postmortem

Date of Incident: 23-July-2026
Region Affected: US
Duration: 14:10 UTC – 16:40 UTC
Severity: Partial degradation (no data loss)

Summary

On the date above, customers in the US region using document-level instant learning models experienced elevated processing times on app.nanonets.com. The issue was isolated to document-level model processing and did not affect other regions or services.

Impact

Users submitting documents for processing via document-level instant learning models in the US region saw delayed responses and higher-than-normal latency during the incident window. No documents or data were lost, and all queued requests were processed once the issue was resolved.

Root Cause

An internal message-processing component responsible for routing document jobs to our instant learning models encountered a permissions fault that prevented it from passing messages through as expected. This caused jobs to back up in the processing queue, which in turn drove up response times for affected requests.

Resolution

Our engineering team identified the faulty component, corrected the permissions issue, and restored normal message flow. The backlog of queued documents was drained and fully processed shortly after the fix was applied. Service returned to normal operating latency by 16:40 UTC.

We sincerely apologize for the inconvenience this caused and we are implementing stricter safeguards to prevent a recurrence

Posted Jul 23, 2026 - 17:40 UTC

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2026 - 16:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 23, 2026 - 16:19 UTC

Investigating

We are currently investigating this issue.
Posted Jul 23, 2026 - 15:55 UTC
This incident affected: API.