Service Disruption Due to Global AWS Outage

Incident Report for Nanonets

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 21:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 21:28 UTC

Identified

On 20th Oct, a global AWS outage impacted one of our feature flag service providers, resulting in intermittent failures for some of our models. The issue originated from the provider's infrastructure dependency on affected AWS regions, which caused disruptions in feature flag evaluations within our system. Our engineering team promptly identified the root cause and implemented mitigation measures to restore functionality. We are continuously monitoring the situation and working with our partners to ensure full stability. We apologize for the inconvenience caused and appreciate your patience and understanding.
Posted Oct 20, 2025 - 21:11 UTC
This incident affected: API and Web App.