Delayed file processing for models in app.nanonets.com

Incident Report for Nanonets

Postmortem

On 21st September 2026 between 15:00 UTC and 16:30 UTC, some customers experienced delayed document processing and intermittent request failures across multiple models. The cause was an internal resource-accounting component in our model gateway that entered a repeated retry loop. This exhausted connection capacity on the affected service and caused a subset of processing nodes to restart, slowing throughput. We identified the root cause and applied a configuration change that resolved the issue, with service returning to normal by 15:30 UTC and most files were processed before 16:30 UTC. A permanent fix to the underlying component is being rolled out, along with additional monitoring to detect this condition earlier. We sincerely apologize for the inconvenience this caused and we are implementing stricter safeguards to prevent a recurrence

Posted Sep 21, 2026 - 17:38 UTC

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 16:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2026 - 16:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 21, 2026 - 15:52 UTC

Investigating

We are currently investigating this issue.
Posted Sep 21, 2026 - 15:21 UTC
This incident affected: API.