App is down in EU region.
Incident Report for Nanonets
Postmortem

Incident Summary: On 13-Jan-2025 07:42 PM IST an incident occurred where our application became temporarily unavailable. This affected the following services:

The outage was caused by an accidental deletion of an authorization token required for database authentication. This token is essential for ensuring secure and seamless communication between the application and the database.

Resolution:
A new authorization token was generated and securely updated in the system. Services were restarted, and normal functionality was verified. We will introduce stricter permissions to ensure only authorized personnel can manage critical tokens. We sincerely apologize for the inconvenience caused by this incident. We acknowledge the importance of our services to your operations and deeply regret this unintentional disruption. Please be assured that we are taking all necessary steps to prevent such incidents in the future.

Timeline:
13-Jan-2025 07:42 PM IST to 13-Jan-2025 07:54 PM IST

Posted Jan 13, 2025 - 14:42 UTC

Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 14:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2025 - 14:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2025 - 14:24 UTC
Investigating
Only https://eu.nanonets.com and https://eu-open.nanonets.com are affected. https://app.nanonets.com is working as expected
Posted Jan 13, 2025 - 14:20 UTC
This incident affected: API and Web App.